Jump to content

I just want to know why..Read on please


Recommended Posts

I've got a laptop at home, which I effectively use as a desktop....It never moves.


If memory serves, it's an Asus....I've got a multi USB adapter which permanently resides in 'one' of the two USB ports...Running an external keyboard, and a 'proper' mouse, wirelessly.


As we all know the sound quality of the built in speakers is rubbish, so on Saturday I bought a pair of cheapish speakers. Plugged them into the available USB port, and they worked perfectly....However...


On Sunday, I booted the computer as usual, and tried to access the internet. When it said there wasn't a wireless adapter fitted....Which is rubbish, I've always used it wirelessly. I fiddled with the settings, to no avail...Rebooted, no luck....Restored it to a previous date...No luck....Switched off the modem and rebooted that....No luck....Trawled through all the settings (it's running Vista)...It simply said there was no network adapter....So therefore, couldn't connect to the internet.


I pondered upon it for a long while...Fiddled some more....Then asked myself, "What's changed?".....Well, the only thing different was the speakers, and they had worked perfectly the day before....But that was the only thing different....But the logic to me, was that the speakers were only drawing a 5 volt power supply from the USB port...they weren't interacting with the computer as such. Anyway, I completely disconnected the speakers....And yes, you've guessed, the computer worked properly once more.


So, I solved the problem, but can't understand why the speakers caused a 'problem'.


Anyone any clues?

Edited by PeteMorris
Link to comment
Share on other sites

Does your wireless settings have some kind of power control??


Perhaps the USB hub drew too much current so the computer shut down the wireless car to provide the juice???


I'm not aware of any power controls for the wireless aspect. There's a sort of a on off keyboard combination, where you can turn it off or on, and I did check it hadn't inadvertently been switched off.


I've never had any 'issues' with the USB hub....The speaker power was plugged into a direct USB port...Not the hub.


But I'm wondering now if it might be an overload of power going the the speakers.....hmmmmm

Link to comment
Share on other sites

Are they actually USB speakers, if so it's not just power, they are a USB device themself.


Vista is rubbish though, I'd recommend upgrading it and you'll have less issues in general.


As far as I know, they're not USB speakers as such, cos there's a phono lead which plugs into the laptop headphone socket to provide the sound signal...There's no mains lead, just a USB which plugs into the lappy to provide the power.


Yes I know Vista is crap...:) The computer is a few years old and I'm seeing it out, to it's death... :)

Link to comment
Share on other sites

Yep, you need a powered hub instead. If it is running Vista the power overhead will be tiny (old machine).


As you bought cheap speakers chances are that they don't have the most reliable electronics in them either.

Link to comment
Share on other sites

In that case, over drawing of the power is the most likely culprit.


You could power them from a phone charger or from the hub (if the hub has a power supply) to avoid the problem.


Would simply overdrawing power from the USB cause a shutdown of one or other system?....And that being the case, I wonder why they worked when I first plugged them in? It wasn't until the following day, when I booted up, that the wifi went down?


I'll try the alternatives you suggest...as the hub is definitely a powered device...and failing that I'll try the phone charger.



Link to comment
Share on other sites

Yep, you need a powered hub instead. If it is running Vista the power overhead will be tiny (old machine).


As you bought cheap speakers chances are that they don't have the most reliable electronics in them either.


Oooops...Sorry Tim, I didn't see your reply before I responded to Cyclone. So it looks like it was definitely a power drain, caused by the speakers.


---------- Post added 09-03-2015 at 12:40 ----------


It could be that the maximum through-put of the USB port is exceeded as well, is it USB1?


It shouldn't be that, but as you say, it is old gear, things can go wrong and all that.


TBH I'm not sure which version of USB it has....I don't think it's the original USB, cos I've never had messages saying "this device can run faster ....Blah blah"...So it's probably USB 2....It's definitely not 3 either...:)


---------- Post added 09-03-2015 at 18:54 ----------




I've plugged the speakers into the 'powered' USB port and it seems to be fine...God knows why it worked initially, and on reboot fell over....But the speakers are working now, and so is the wifi...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.