Jump to content

Simfer Fan Assisted Elecretic Oven

Recommended Posts

Last week whilst cooking i realised that my cooker has tripped the fuse, so i flicked the switch & it seemed to work again next day i tried to turn on the oven to cook dinner to find that although i can hear the fan (in the oven) & the grill & hob all work fine for some reason the oven isnt getting hot, up to now iv had no problems at all with it infact its been the best cooker iv ever owned, although iv only had it 26 moths, my question is as money is very tight is this an expensive problem , am i as well just getting a second hand replacement, thought i  would ask on here before contacting anyone as id rather have some idea of what is this issue before i go any furthere with this matter

"thank you for reading & appreciate ant help "

Share this post


Link to post
Share on other sites

sounds like the heating element has gone, mine did the same as your description.

Share this post


Link to post
Share on other sites

Not suggesting you aren't clean, but it's worth just cleaning the heating element in case it has become covered in fat or cooking debris as this can cause it to short out.  If that doesn't work then you are probably looking at a new element.

 

I'd get a routine electrician to come and fit one for you if so.  Unless you have a warranty/extended warranty?

Share this post


Link to post
Share on other sites

PM sent

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.