Jump to content

Using Huawei p smart in Iceland (the country)

Recommended Posts

Help! I am in Iceland (country!) at the minute and my phone says emergency calls only. I'm with EE. When I was flying here I put it on airplane mode and it's only since then it's happening. Can anyone help please

Share this post


Link to post
Share on other sites

If you took it out of Airplane mode, and it now says "Emergency Calls Only" then that means it cannot find a signal or network it can use...
 

I know it's no use now, but did you text ROAMING to 150 before heading over?

have a read here... https://community.ee.co.uk/t5/Roaming/EE-roaming-Getting-ready-to-use-your-phone-abroad/td-p/674154

Share this post


Link to post
Share on other sites

Thank you for that.

 

I've read it. Is there anything I can do now to get it back to normal now (sorry I'm not up on mobiles at all). I appreciate your advice. I can use the internet but can't ring or text message 

Share this post


Link to post
Share on other sites

Other than contacting EE's help - I don't think so....

Share this post


Link to post
Share on other sites

The last time I was on EE (it was Orange then) and had no problems so I suspect it is your handset/settings.

 

It might be worth sticking your SIM in someone elses (unlocked) phone just to check that you don't have any restrictions on making calls and sending texts.

 

Are you recieving calls/texts?

Share this post


Link to post
Share on other sites

Good point made above - check in your network settings if you have Roaming enabled...

Share this post


Link to post
Share on other sites
2 hours ago, Top Cats Hat said:

The last time I was on EE (it was Orange then) and had no problems so I suspect it is your handset/settings.

 

It might be worth sticking your SIM in someone elses (unlocked) phone just to check that you don't have any restrictions on making calls and sending texts.

 

Are you recieving calls/texts?

No. When someone rings it says "this number is temporarily unavailable, please try again later"

Share this post


Link to post
Share on other sites

You need to call EE and ask them to enable roaming on your account. Same thing happened to me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.