Jump to content

Adding Komodo Edit to the "other applications" list in Linux Mint


liam1412

Recommended Posts

Hi Linux Gurus

 

I have installed Komodo Edit in Linux Mint, but it is not available in the list of other applications when I right click a file. Is there a way to get it added or even better, just browse the file system for any application.

 

Mint is based on Ubuntu 11.10 if you haven't used it so it should be the same for both I would imagine

Link to comment
Share on other sites

I'm really liking it so far!!

 

I don't think that is what I am looking for. It's not the launcher, I have sym linked that so the launcher icon appears on the desktop. What I need is when I right click a PHP file in my doc route Komodo Edit is not in the list of apps I can use. Neither is it there when I go into properties and try to change the file association. So at the moment every time I want to open a file in Komodo edit I have to file->open inside Komodo which all though only a little thing, is bloody annoying.

 

I think it is something to do with the .desktop file but been a noob I don't want to tinker too much and break it!

Link to comment
Share on other sites

I have found a tut asking me to create a komodo.desktop file at the following location

 

~/.local/share/applications

 

With the following contents

 

[Desktop Entry]
Encoding=UTF-8
Name=komodo
Comment=Something something
Exec=komodo
Terminal=false
Type=Application
Icon=
Categories=Application;
StartupNotify=true
MimeType=text/plain;
NoDisplay=true

 

Which I have done, but it still isn't in the list of other applications that the file can be opened with :-/

Link to comment
Share on other sites

I think you may be able to use the update-alternatives command.

 

For example I installed a few browsers on Ubuntu for testing site designs, & to specify which I wanted as the default I had to run...

 

sudo update-alternatives --config x-www-browser

 

...which would then show a list of browsers. As long as you've installed the program using apt-get, aptitude, or dpkg from a .deb file the system should know what the program is for, so if you find the string to replace x-www-browser in the command above to change alternative editors you may be able to specify it as the default from there.

 

If it's annoying you that much then in the short term you could install bluefish. It's a lightweight editor that should do roughly the same job, & it'll give you something other than gedit/gVim/kate/whatever in the right-click menu until you sort it out.

Link to comment
Share on other sites

I have found a tut asking me to create a komodo.desktop file at the following location

 

~/.local/share/applications

 

With the following contents

 

[Desktop Entry]
Encoding=UTF-8
Name=komodo
Comment=Something something
Exec=komodo
Terminal=false
Type=Application
Icon=
Categories=Application;
StartupNotify=true
MimeType=text/plain;
NoDisplay=true

 

Which I have done, but it still isn't in the list of other applications that the file can be opened with :-/

 

Could it be something to do with this?

https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/455344

 

http://manpages.ubuntu.com/manpages/gutsy/man1/update-mime-database.1.html

 

Have you asked on Ubuntu forums?

Link to comment
Share on other sites

It hasn't been installed using apt-get as it isn't available as a package. I have bluefish, but I like the PHP tooltips that Komodo gives. Save's me loads of time in looking on php.net for what I need to pass to functions and in which order.

 

I'm not sure if that bug is related or not. I'll try posting on the Ubuntu forums. Thanks for the help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.