Jump to content


Talk Talk Internet problems Megathread

Recommended Posts

I have connection problems in S10 near the cemetary. Does anyone else just lose their talk-talk connection for no reason? Had ten minutes connection tonight.

 

It's always dead slow around the cemetery

Share this post


Link to post
Share on other sites
There's another thread on this board about this. But in S8. I solved my problem by switching the router off for a whole weekend (I went away) & it's been pretty stable ever since. Maybe try something like that? Talk talk are utterly useless, I'll be leaving in June when my contract is up.

 

You don't have to switch it off for that long. Unplug the power for ten seconds (count to 20 in your head) and plug it back in. It will seek a new path then and usually fix the issue.

Share this post


Link to post
Share on other sites

Well, that didn't last long. Came home from work to find my router is not connected to the internet. I cannot wait to be rid of this shambles of a **** poor company.

Share this post


Link to post
Share on other sites

Well sorry to hear that - partner of eldest states that there are issues with broadband in a part of Sheffield that TT can do nothing about due to infrastructure problem = BT Openreach problem; who are not prepared to do anything about it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

X