Jump to content

Anybody know owt about Cisco routers?

Recommended Posts

HELP! I have a Cisco 837 router which I am trying to configure to work with my Plusnet ADSL account and Plusnet aren't being especially helpful as they 'don't offer support on 3rd party hardware' which is understandable.

 

I am using SDM version 2.5 as the programming tool and I have configured the ADSL interface OK but when I run the connection test it gets as far as "Testing exit interface" and then tells me that I have to configure either a user-specific or a default route through this interface, and this is where I come unstuck as I don't know what I need to do here.

 

I have looked in the routing section of the SDM and I can see where I add a default route but I don't know what values need to be in there.

 

Can anyone help me?

Share this post


Link to post
Share on other sites

Hi mate

I know a bit about Cisco and routing ;-) but apologies, my game is the bigger boxes and command line stuff so I don't profess any intimacy with SDM and 8xx series though I know what they are.

 

So your DSL int is up, and you can obviously get to the router. You don't say if you get your address via dhcp or static, but either way from what you say it is expecting a default route.

 

What this means is that your pc, when you try and communicate, looks at the target address, and establishes if it's on the same network. If so it sorts it. If not it needs to know where to send it (default gateway).

 

Same with the router. It knows about it's LAN int, but what does it do with anything else? (default route)

 

It has to send it to the gateway on the other end of the WAN link. So your route should be something like this, <dest address> <mask> <where to send it>

I dunno which boxes in SDM you'll enter them in but try this

 

0.0.0.0 (that's the target address - I know it looks odd)

0.0.0.0 (that's a wildcard mask to mean anything)

ADSL or ATM0 or whatever (your outgoing interface)

 

if the outgoing interface was ATM0, then via the command line i'd do the following

connect to router

enter enable mode

ip route 0.0.0.0 0.0.0.0 atm0

 

and save the config

Hope this helps, but if you have further issues, PM me your config, and I'll wheel SDM out and help you with it

Share this post


Link to post
Share on other sites

This is the config...

 

Router#show run

Building configuration...

 

Current configuration : 1383 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

logging queue-limit 100

!

username administrator privilege 15 password 0 xxxxxxxxxx

ip subnet-zero

ip name-server 212.159.6.9

ip name-server 212.159.6.10

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool DPA

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 212.159.6.9

!

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

!

!

partition flash 2 6 2

!

!

!

!

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 0/38

encapsulation aal5snap

protocol ppp dialer

dialer pool-member 1

!

!

interface Dialer0

ip address 81.174.133.36 255.0.0.0

encapsulation ppp

dialer pool 1

dialer-group 1

dialer-group 1

ppp chap hostname xxxxxxx@yyyyyyy

ppp chap password 0 xxxxxxxx

ppp pap sent-username xxxxxx@yyyyyyy password 0 xxxxxxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 ATM0.1

ip http server

ip http authentication local

ip http secure-server

!

dialer-list 1 protocol ip permit

!

line con 0

no modem enable

stopbits 1

line aux 0

line vty 0 4

!

scheduler max-task-time 5000

!

end

 

Router#

Router#

Share this post


Link to post
Share on other sites

I have never used SDM on a Cisco router just Hyperterminal and a console cable. If you can access the router via console you could try the config below which is what I use to get routers connected for another ISP, hopefully Plusnet use the same settings. I have copied your network settings from the existing config, so hopefully they are correct. Back up your current config first though just in case ;-)

 

Console onto the router and switch to enable mode

 

Router>enable

Router#wr erase (This will delete your current config)

Router#reload (This will restart your router)

 

Once reloaded, switch to enable mode again and then configure terminal. If the router asks if you want to enter intial configuration say no.

 

Router>enable

Router#conf t

Router (config)#

 

Once at this prompt paste the config below to your router. With Hyperterminal you may have to click edit, paste to host rather than ctrl+v shortcut.

 

username administrator privilege 15 password xxxxxxxxxx (change to required password)

!

ip dhcp excluded-address 192.168.0.1

!

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

hold-queue 100 out

!

ip dhcp pool DPA

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 212.159.6.9

!

interface ATM0

no ip address

snmp ifindex persist

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

no shut

!

!

interface Dialer1

ip address negotiated

ip mtu 1420

encapsulation ppp

dialer pool 1

dialer-group 1

snmp ifindex persist

ppp authentication chap callin

ppp chap hostname xxxxxxxxxxxxxxx (change to required username)

ppp chap password xxxxxxxxxxxxxxx (change to required password)

no shut

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

end

 

The 837 looks very much like a Soho97 router, so if my memory serves me the CD light should start flashing, then stay on constant and the RXD and TXD lights should flash away. On the router type

 

Router#sh ip int brief

 

and hopefully interface dialer1 will show up up and have your static IP address assigned. The config does assume that even though you have a static address Plusnet are assigning it dynamically. If the router is up up and has your static ip address attach a PC via a network and see if you can connect to the outside world.

 

If the router is not connected try typing on the router

 

Router#debug ppp auth

 

and this should tell you if the username or password is being rejected. If you want to set your router back to your original config, switch the router off and back on, switch to enable mode and configure terminal

 

Router>enable

Router#conf t

Router (config)#

 

and paste your original config back to the router. Hope this helps.

Share this post


Link to post
Share on other sites

Thanks very much Ian Cognito. This setup seems to be working OK in as much as the connection tests on the router are all passing as successful. I can see that I am receiving the correct IP address from my ISP and using Hyperterminal I can ping the IP address of the DNS server OK, but I still can't access the outside world from my PC.

 

I've got DHCP set up on the router and the PC is acquiring the IP address OK and is showing the correct default gateway (Ip address of the router). I'm at a loss to understand it.

Share this post


Link to post
Share on other sites

Sorted it. I didn't realise I had to create a NAT rule to associate the ethernet with the Dialer1 interface. It's all working now.

 

Thanks for your assistance.

Share this post


Link to post
Share on other sites

Nearly there mate

 

Remove the line ip route 0.0.0.0 0.0.0.0 ATM0.1 and add the line ip route 0.0.0.0 0.0.0.0 dialer0

 

Your problem comes from 255.0.0.0 mask. This means that the other end will be in a quandary as to what to do with the return traffic as you are one in 16 million addresses in that 81.x.x.x range. The interface wont take that 32 bit mask, so I think you have been misled by the ISP. Try this

 

Configure a loopback interface

 

conf t

int loop0

ip address 81.174.133.36 255.255.255.255

 

remove the ip address form dialer0 then refer to the loopback

 

int dialer0

no ip address

ip unnumbered loop0

 

and see how you go with that

 

If ok save the config! ;-0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.