Sheffield Forum
Your message here

Samsung Galaxy S2 drivers for USB cable for Windows 7

Home > General > Computer & Tech Chat

Reply To Topic
 
Thread Tools Search this Thread
31-12-2011, 17:46   #1
Rich
DS,Xbox360 gamer
Rich's Avatar
 
Joined: Sep 2003
Location: S3 Netherthorpe (Stannington on weekends)
Total Posts: 29,498
Send a message via ICQ to Rich Send a message via MSN to Rich Send a message via Yahoo to Rich Send a message via Skype™ to Rich
Topic.

Just plugged my data cable into my Galaxy S2 to download some pics I took recently, it says on Dad's PC that the drivers are not installed for the phone! Can anyone tell me where I can get Windows 7 flavour drivers to get my USB cable to work? I need them tonight if possible.

All I found on Google was an S2 "Studio", which is installing as I type.
  Reply With Quote
31-12-2011, 17:56   #2
alternageek
LI Moderator
alternageek's Avatar
 
Moderator
Joined: Jul 2004
Location: Meersbrook
Total Posts: 5,708
http://www.samsung.com/uk/function/s...galaxy+s2&b2b=
It appears you can search by specific model number of your phone for specific drivers, but these are all the available downloads on Samsungs site for searching by Galaxy S2
  Reply With Quote
31-12-2011, 17:57   #3
Sid Umpley
Account Closed
 
Joined: Nov 2008
Location: Walkley
Total Posts: 1,621
they are not needed. win7 should recognise the phone automatically.

i you have any problems you can always re instal Kies from http://www.samsung.com/uk/support/us...tware/KIES/JSP

that will sort out any driver issues you could have though
  Reply With Quote
31-12-2011, 18:14   #4
AdamDowning
Registered User
 
Joined: Aug 2011
Total Posts: 180
I'd recommend re-installing Kies. This is what we do at O2 and it sorts driver issues.

Uninstall Kies
Reboot
Install Kies
Reboot computer and phone
Plug phone in
  Reply With Quote
31-12-2011, 19:47   #5
Rich
DS,Xbox360 gamer
Rich's Avatar
 
Joined: Sep 2003
Location: S3 Netherthorpe (Stannington on weekends)
Total Posts: 29,498
Send a message via ICQ to Rich Send a message via MSN to Rich Send a message via Yahoo to Rich Send a message via Skype™ to Rich
I managed to get it working with Kies, and downloaded my pics in Picasa.
  Reply With Quote
31-12-2011, 21:53   #6
Assassin007
Registered User
Assassin007's Avatar
 
Joined: Nov 2011
Total Posts: 429
Quote:
Originally Posted by Rich View Post
I managed to get it working with Kies, and downloaded my pics in Picasa.
Hi,

By any chance is your Dad's machine running Windows 7 x64? If so, then the drivers, at times, are known to be troublesome.

If you just want the driver and not kies, then this driver should work fine.

http://www.mediafire.com/?mmzzyhkxq7n3bph

Regards,

A
_______

Our lives begin to end the day we become silent about things that matter
  Reply With Quote
31-12-2011, 22:10   #7
Rich
DS,Xbox360 gamer
Rich's Avatar
 
Joined: Sep 2003
Location: S3 Netherthorpe (Stannington on weekends)
Total Posts: 29,498
Send a message via ICQ to Rich Send a message via MSN to Rich Send a message via Yahoo to Rich Send a message via Skype™ to Rich
Quote:
Originally Posted by Assassin007 View Post
Hi,

By any chance is your Dad's machine running Windows 7 x64? If so, then the drivers, at times, are known to be troublesome.

If you just want the driver and not kies, then this driver should work fine.

http://www.mediafire.com/?mmzzyhkxq7n3bph

Regards,

A
Thanks for that, might come in handy.

Happy new year
  Reply With Quote
31-12-2011, 22:37   #8
walkerx
Registered User
 
Joined: Sep 2010
Total Posts: 1,021
Im running win7 both 32 and 64 bit versions and not had any problems with my sgs2 connecting. both versions found drivers automatically
_______
ISP: Unlimited BT Infinity 2|76Mbps/16Mbps|HG612 (modded)|TP-Link Archer C7|BT HH5|D-Link Dir 825|2 x TL-SG1005D|HP ProCurve 1810G
Media Playback:2 x YouView|Xbox One/ASUS Transformer|PCH C-200
  Reply With Quote
Reply To Topic

Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT. The time now is 03:43.
POSTS ON THIS FORUM ARE NOT ACTIVELY MONITORED
Click "Report Post" under any post which may breach our terms of use.
©2002-2014 Sheffield Forum | Powered by vBulletin ©2014