View Full Version : Save ****.cfg from notepad?


Wayneos
24-10-2006, 12:28
Hi there, wonder if anyone can help, I have several cheats that advise me to open a .cfg (config) file in notepad, edit it and save it again as a .cfg.

Just wondering if anyone could advise me how the hell you do this as I don't get that option and when I press ctrl + s I get prompted to save as a .txt, .doc etc etc, depending on what text program I open...


NB: I cannot accept any downloads or anything so please don't send them.

Thanks all....

zach
24-10-2006, 12:37
Open a Window

Go to Tools at the top, Then Folder Options, Then to View and in that menu just clear the "Hide Extentions to know file types" box

That might sort it for you

Wayneos
24-10-2006, 12:44
Sounds worth a shot but don't imagine that'll do anything cos the pc will still know the extension and therefore still need t know what extension to use when saving, I think, and it is literally just a thought and tell me shut up if you know i'm wrong but I think thats just for a tidy look.

zach
24-10-2006, 12:46
Well it doesn't really work like that but have faith... I always have that option unticked to create batch files etc... and it does allow me to create
.cfg files.

EDIT: Also when you create your file, dont forget to add the extention eg test.cfg Dont just call it test

CorpG
24-10-2006, 12:48
If you open an existing cfg file in notepad ie file.cfg, pressing 'save as' should open the save file dialog box and 'file.cfg' should already be written for you in the filename section, click save and it will prompt you to overwrite and will retain the .cfg extension. Ignore the 'Save as Type' bit. Pressing ctrl-s or 'save' should just save the file with the same name automatically rather than open the dialog.

If its a new file that you are creating, when you go to save the file just type in the name including the extension ie. 'file.cfg' It should save it as a cfg file. Again, Ignore the 'Save as Type' bit

You may also need to change your settings (as zach describes) to make this work. Not sure tho.

Cyclone
24-10-2006, 12:57
If you just type test.cfg as a filename in the notepad save dialogue you will get test.cfg.txt as your filename. Change the filetype to 'All Files' then use the name test.cfg and it will work.

Wayneos
24-10-2006, 12:58
Thanks Guys, I'll Give Them A Go...

dosxuk
24-10-2006, 13:28
If you've opened a file, then editing, then pressing ctrl+s and it comes up with a save as box, it probably means the file is read only. Check the file properties in explorer.

sccsux
24-10-2006, 13:48
If you just type test.cfg as a filename in the notepad save dialogue you will get test.cfg.txt as your filename.


Or (as I do) simply type the name and extension, but surrounded by quotes:

"name.cfg"

The quotes stop any default extension being applied:thumbsup:

Cyclone
24-10-2006, 13:49
cool, didn't know that.

Wayneos
24-10-2006, 13:53
cool, didn't know that.

ME NEITHER, YA LEARN SUMMIT NEW EVERY DAY....APPARENTLY....I HAVE ABOUT 364 DAYS MISSING SOMEWHERE :hihi:

esme
24-10-2006, 14:39
I like PFE32 (http://www.lancs.ac.uk/staff/steveb/cpaap/pfe/default.htm) for editing text files, notepad can't handle big files and wordpad is rather limited for plain text as it's got all the bells and whistles for a wannabe word processor and plain text is a bit beneath it

PFE32 is nice and simple doesn't attempt to be too clever but has advanced features should should you want them

Nazo
24-10-2006, 14:57
Bit of geek trivia: type the following (exactly) into Notepad:

this app can break

save it, close Notepad, reload. Tadaa!

Wayneos
24-10-2006, 15:00
Bit of geek trivia: type the following (exactly) into Notepad:

this app can break

save it, close Notepad, reload. Tadaa!

NOT SURE I LIKE THE SOUND OF THAT, WHAT'S THE OUTCOME..?

xircon
24-10-2006, 15:44
Its a testing "easter egg" for MS techies, there is one in Word as well that types "the quick brown fox ........... " hundreds of times

Nazo
24-10-2006, 21:39
No it's a bug in the way Notepad handles some text strings. When you reload the page the text is all in Chinese.
I've had it happen with genuine text files that I've been working on, very annoying! Kind of amusing that this particular sentence triggers it though.